List Currently Experiencing Issues
Incident Report for InventoryLab Inc.
Resolved
The listing outage has been fixed!
Posted Aug 09, 2021 - 22:06 UTC
Investigating
There is currently an issue with listing and searching under the List tab. We are currently looking into the root cause at a high priority.
Posted Aug 09, 2021 - 21:50 UTC
This incident affected: InventoryLab (List).