InventoryLab is currently experiencing issues with List and Inventory
Incident Report for InventoryLab Inc.
Resolved
The issues with the inventory and list pages have been resolved. Thank you for your patience while we worked on this.
Posted Jul 06, 2022 - 20:13 UTC
Identified
There is currently an issue with the List & Prep and Inventory pages. Our team has identified the issue and is working to resolve it at a high priority. We will update once there is more information or a resolution.
Posted Jul 06, 2022 - 17:49 UTC
This incident affected: InventoryLab (List, Inventory).