InventoryLab is currently experiencing log in issues
Incident Report for InventoryLab Inc.
Resolved
The previous issues with using InventoryLab has been resolved. If you are still experiencing problems with logging in, please reach out to support@inventorylab.com
Posted Dec 13, 2022 - 17:04 UTC
Identified
Our team is currently working to resolve this issue at a high priority.
Posted Dec 13, 2022 - 16:09 UTC
This incident affected: InventoryLab (Research, List, Inventory, Accounting, Reports, Settings, Account Management).