InventoryLab Down
Incident Report for InventoryLab Inc.
Resolved
The issues with InventoryLab have now been resolved.

Thank you for your patience while we worked on this!
Posted May 27, 2021 - 10:40 UTC
Identified
InventoryLab is currently experiencing issues. You may be unable to log in or take any actions within your account.

Our development team is working to resolve this at a high priority. We will update everyone once the issue has been fixed. We apologize for any inconvenience this may cause.

Thank you for your patience while we work on this.
Posted May 27, 2021 - 10:16 UTC
This incident affected: InventoryLab (Research, List, Inventory, Accounting, Reports, Settings, Account Management).